[转]linux下创建virtualenv时指定python版本

2018/10 07 21:10

virtualenv是python开发中一个重要的工具,它可以帮助我们创建一个干净的python解释环境,创建虚拟环境时,这个虚拟环境的
python版本往往是系统默认的2.x版本.别急,我们只需要一条简单的命令就可以创建一个python3.x的虚拟环境

virtualenv -p /usr/bin/python3 py3env

其中,py3env是虚拟环境的名称,可以根据自己的需求命名。

注意,前提是你已经安装了python3.x版本

当我们想用python2.x版本的时候,直接

virtualenv venv

或者

virtualenv -p /usr/bin/python py2env

--转载请注明: http://91o.cc/%e8%bd%aclinux%e4%b8%8b%e5%88%9b%e5%bb%bavirtualenv%e6%97%b6%e6%8c%87%e5%ae%9apython%e7%89%88%e6%9c%ac/

作者 - 分类 未分类

发表回复

(必填)